aboutsummaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 53885a83..8019bd37 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -39,8 +39,14 @@ mocks = [
'-Wl,--wrap=write',
'-Wl,--wrap=fopen',
'-Wl,--wrap=fopen64',
+ '-Wl,--wrap=fwrite',
+ '-Wl,--wrap=fflush',
'-Wl,--wrap=stat',
'-Wl,--wrap=stat64',
+ '-Wl,--wrap=fstat',
+ '-Wl,--wrap=fstat64',
+ '-Wl,--wrap=fileno',
+ '-Wl,--wrap=fsync',
'-Wl,--wrap=fread',
'-Wl,--wrap=fgets',
'-Wl,--wrap=fclose',