aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3a60f92d..366ce18a 100644
--- a/meson.build
+++ b/meson.build
@@ -500,7 +500,11 @@ endif
# `.allowed()` gets introduced in 0.59.0
if get_option('tests').auto() or get_option('tests').enabled()
# unit-test framework
- cmocka = dependency('cmocka', required : get_option('tests'))
+ cmocka_dep = dependency(
+ 'cmocka',
+ fallback: ['cmocka', 'cmocka_dep'],
+ required : get_option('tests')
+ )
flashrom_test_dep = declare_dependency(
include_directories : include_dir,
@@ -519,7 +523,7 @@ if get_option('tests').auto() or get_option('tests').enabled()
],
)
- if cmocka.found()
+ if cmocka_dep.found()
subdir('tests')
endif
endif