aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Heijligen <thomas.heijligen@secunet.de>2021-10-12 16:47:43 +0200
committerNico Huber <nico.h@gmx.de>2021-10-15 14:35:38 +0000
commitb5836478888acf38780ae1ec0315282778916d2a (patch)
tree72cbf84d1371dc51b0cf0d971be93e4e13d9e264 /meson.build
parentba1c5eb12591c306604929b94b9046a37170c5ff (diff)
downloadflashrom-b5836478888acf38780ae1ec0315282778916d2a.tar.gz
flashrom-b5836478888acf38780ae1ec0315282778916d2a.tar.bz2
flashrom-b5836478888acf38780ae1ec0315282778916d2a.zip
buildsystem: Determine the endianness only in the buildsystem
Let the buildsystem (make / meson) handle the endianness determination and set the __FLASHROM_LITTLE_ENDIAN__ or __FLASHROM_BIG_ENDIAN__ macro as cflag. Change-Id: I37093528ae55e712cc30a0267a8ceac332750e7d Signed-off-by: Thomas Heijligen <thomas.heijligen@secunet.de> Reviewed-on: https://review.coreboot.org/c/flashrom/+/58273 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Nico Huber <nico.h@gmx.de> Reviewed-by: Felix Singer <felixsinger@posteo.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1a36df88..02dedfcf 100644
--- a/meson.build
+++ b/meson.build
@@ -29,6 +29,13 @@ add_project_arguments('-D_POSIX_C_SOURCE=200809L', language : 'c') # required fo
add_project_arguments('-D_BSD_SOURCE', language : 'c') # required for glibc < v2.19
add_project_arguments('-DFLASHROM_VERSION="' + meson.project_version() + '"', language : 'c')
+if host_machine.endian() == 'little'
+ add_project_arguments('-D__FLASHROM_LITTLE_ENDIAN__=1', language : 'c')
+endif
+if host_machine.endian() == 'big'
+ add_project_arguments('-D__FLASHROM_BIG_ENDIAN__=1', language : 'c')
+endif
+
# get defaults from configure
config_atahpt = get_option('config_atahpt')
config_atapromise = get_option('config_atapromise')