aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorNikolai Artemiev <nartemiev@google.com>2020-10-06 16:59:51 +1100
committerEdward O'Callaghan <quasisec@chromium.org>2020-12-03 12:31:33 +0000
commitadbae0e2681a994520ea551bd2f66b06de0b0899 (patch)
treea9ac2edd308fac78303ab0c2347b8a919720d6c0 /meson.build
parentf745d0e6ab85f84b482aeac2ac4975e26db57389 (diff)
downloadflashrom-adbae0e2681a994520ea551bd2f66b06de0b0899.tar.gz
flashrom-adbae0e2681a994520ea551bd2f66b06de0b0899.tar.bz2
flashrom-adbae0e2681a994520ea551bd2f66b06de0b0899.zip
s25f.c: implement probing and block erasers for Spansion
This adds support for Spansion 25Fxxxxx chips. These chips require their own probing logic because the first 6 bytes returned by RDID must be examined to identify the chip. New erase functions are required as the chips support multiple sector layouts, and the default layout must be changed to be able to erase the entire flash. Adapted from cros flashrom at `9c4c9a56b6a0370b383df9c75d71b3bd469e672d`. BUG=b:153800073 TEST=builds Signed-off-by: Nikolai Artemiev <nartemiev@google.com> Change-Id: I2d23f9c36ce8b2959807fbeee7f60e02444e3763 Reviewed-on: https://review.coreboot.org/c/flashrom/+/46140 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1acbdb35..fd5a5ef7 100644
--- a/meson.build
+++ b/meson.build
@@ -354,6 +354,7 @@ srcs += 'libflashrom.c'
srcs += 'opaque.c'
srcs += 'print.c'
srcs += 'programmer.c'
+srcs += 's25f.c'
srcs += 'sfdp.c'
srcs += 'spi25.c'
srcs += 'spi25_statusreg.c'