aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Badea <vamposdecampos@gmail.com>2023-02-13 03:03:26 +0000
committerThomas Heijligen <src@posteo.de>2023-02-27 09:47:44 +0000
commit83b051a9b4080382bef1c1b3366b2c4d3b52b979 (patch)
treebb265597b19fda9addb537c344e6ccf6fb566065 /meson.build
parentc4655409bb79899a748c5fa83b01c143a544a3a5 (diff)
downloadflashrom-83b051a9b4080382bef1c1b3366b2c4d3b52b979.tar.gz
flashrom-83b051a9b4080382bef1c1b3366b2c4d3b52b979.tar.bz2
flashrom-83b051a9b4080382bef1c1b3366b2c4d3b52b979.zip
asm106x: add programmer for ASM106x SATA controllers
The ASMedia ASM106x series is a PCIe-SATA controller chip. It supports an attached SPI flash chip that can contain configuration and PCI option ROM. The interface is a simple shifter accessed via PCI config space, up to 4 bytes at a time. Add a programmer driver for it. Tested on a G536PCE1061V11 IO-PCE1061-V1.1 PCIe card, and a MPCE2ST-A01 VER006S mini-PCIe card, both with chips marked ASM1061, both enumerate as: 01:00.0 SATA controller [0106]: ASMedia Technology Inc. ASM1062 Serial ATA Controller [1b21:0612] (rev 02) (prog-if 01 [AHCI 1.0]) Subsystem: ASMedia Technology Inc. ASM1062 Serial ATA Controller [1b21:1060] Change-Id: I591b117be911bdb8249247c20530c1cf70f6e70d Signed-off-by: Alex Badea <vamposdecampos@gmail.com> Reviewed-on: https://review.coreboot.org/c/flashrom/+/73037 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Thomas Heijligen <src@posteo.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index baa10846..83fc1202 100644
--- a/meson.build
+++ b/meson.build
@@ -156,6 +156,13 @@ linux_headers = \
# 'active' : boolean, # added on runtime
# }
programmer = {
+ 'asm106x' : {
+ 'systems' : systems_hwaccess,
+ 'deps' : [ libpci ],
+ 'groups' : [ group_pci, group_internal ],
+ 'srcs' : files('asm106x.c', 'pcidev.c'),
+ 'flags' : [ '-DCONFIG_ASM106X=1' ],
+ },
'atahpt' : {
'systems' : systems_hwaccess,
'cpu_families' : cpus_port_io,