aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Campello <campello@chromium.org>2021-03-16 17:17:14 -0600
committerEdward O'Callaghan <quasisec@chromium.org>2021-03-19 00:48:39 +0000
commit0e5ae9577e1f353a47dd46f891fe03aa8ab8e6d7 (patch)
tree076d569492714f4c307c6286bc91378f38d0b7c1 /meson.build
parent8d6ef739b1cb3415dd9fb1162a88d607dd54a6b8 (diff)
downloadflashrom-0e5ae9577e1f353a47dd46f891fe03aa8ab8e6d7.tar.gz
flashrom-0e5ae9577e1f353a47dd46f891fe03aa8ab8e6d7.tar.bz2
flashrom-0e5ae9577e1f353a47dd46f891fe03aa8ab8e6d7.zip
meson: Add print_wiki option
Align meson options to be equivalent to the Makefile as they are used in Gentoo's ebuilds. Signed-off-by: Daniel Campello <campello@chromium.org> Change-Id: I97d2fd687aa21533b86f9af446038bfe3da1f7d3 Reviewed-on: https://review.coreboot.org/c/flashrom/+/51552 Tested-by: build bot (Jenkins) <no-reply@coreboot.org> Reviewed-by: Edward O'Callaghan <quasisec@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 43b0fe44..b7e8c108 100644
--- a/meson.build
+++ b/meson.build
@@ -68,6 +68,7 @@ config_usbblaster_spi = get_option('config_usbblaster_spi')
config_stlinkv3_spi = get_option('config_stlinkv3_spi')
config_lspcon_i2c_spi = get_option('config_lspcon_i2c_spi')
config_realtek_mst_i2c_spi = get_option('config_realtek_mst_i2c_spi')
+config_print_wiki= get_option('print_wiki')
cargs = []
deps = []
@@ -429,6 +430,11 @@ flashrom_dep = declare_dependency(
dependencies : deps
)
+if config_print_wiki
+ srcs += 'print_wiki.c'
+ cargs += '-DCONFIG_PRINT_WIKI=1'
+endif
+
# we can't just link_with libflashrom as we require all the internal symbols...
executable(
'flashrom',