aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMaximilian Hils <git@maximilianhils.com>2016-09-24 21:01:48 -0700
committerGitHub <noreply@github.com>2016-09-24 21:01:48 -0700
commiteeec17902fdcd7de766dc79ed6a2e3a73ad4ce3d (patch)
treee5bf3bfede02873eed266a76bc42039f80e30295 /setup.py
parentde65aebfdf011f1cf68c554ed79326621c328c10 (diff)
downloadmitmproxy-eeec17902fdcd7de766dc79ed6a2e3a73ad4ce3d.tar.gz
mitmproxy-eeec17902fdcd7de766dc79ed6a2e3a73ad4ce3d.tar.bz2
mitmproxy-eeec17902fdcd7de766dc79ed6a2e3a73ad4ce3d.zip
update dependencies, minor fixes (#1577)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 9f75ca15..eec05148 100644
--- a/setup.py
+++ b/setup.py
@@ -64,13 +64,13 @@ setup(
"blinker>=1.4, <1.5",
"click>=6.2, <7.0",
"certifi>=2015.11.20.1", # no semver here - this should always be on the last release!
- "configargparse>=0.10, <0.11",
+ "configargparse>=0.10, <0.12",
"construct>=2.5.2, <2.6",
"cryptography>=1.3, <1.6",
"cssutils>=1.0.1, <1.1",
"Flask>=0.10.1, <0.12",
"h2>=2.4.1, <3",
- "html2text>=2016.1.8, <=2016.5.29",
+ "html2text>=2016.1.8, <=2016.9.19",
"hyperframe>=4.0.1, <5",
"jsbeautifier>=1.6.3, <1.7",
"lxml>=3.5.0, <=3.6.0", # no wheels for 3.6.1 yet.
@@ -103,7 +103,7 @@ setup(
'dev': [
"tox>=2.3, <3",
"mock>=2.0, <2.1",
- "pytest>=2.8.7, <3",
+ "pytest>=3, <3.1",
"pytest-cov>=2.2.1, <3",
"pytest-timeout>=1.0.0, <2",
"pytest-xdist>=1.14, <2",