diff options
author | Aldo Cortesi <aldo@nullcube.com> | 2017-03-16 16:50:41 +1300 |
---|---|---|
committer | Aldo Cortesi <aldo@corte.si> | 2017-03-17 08:13:47 +1300 |
commit | 5192810ff6a41e62e41d16fcf636663d177a1232 (patch) | |
tree | c3fc61680fb63af27df357a198584610772a47b0 /setup.py | |
parent | eac210829e51d988b7090b448037de6d41d5dfe9 (diff) | |
download | mitmproxy-5192810ff6a41e62e41d16fcf636663d177a1232.tar.gz mitmproxy-5192810ff6a41e62e41d16fcf636663d177a1232.tar.bz2 mitmproxy-5192810ff6a41e62e41d16fcf636663d177a1232.zip |
Make mypy succeed with imports on master.py
We get little benefit from our mypy QA checks at the moment, because we skip
imports. This patch is what's needed to make mypy succeed with imports on a
single file: master.py
It also updates mypy to the current version, and enables a QA check.
Mypy bugs I encountered:
dict.update with kwargs not supported:
https://github.com/python/mypy/issues/1031
property setters and getters must be adjacent:
https://github.com/python/mypy/issues/1465
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -96,7 +96,7 @@ setup( 'dev': [ "Flask>=0.10.1, <0.13", "flake8>=3.2.1, <3.4", - "mypy>=0.471, <0.502", + "mypy>=0.501, <0.502", "rstcheck>=2.2, <4.0", "tox>=2.3, <3", "pytest>=3, <3.1", |