aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMarcelo Glezer <mg@tekii.com.ar>2014-12-11 14:54:14 -0300
committerMarcelo Glezer <mg@tekii.com.ar>2014-12-11 14:54:14 -0300
commit4952643a0d76eb1e9bd51cbbe95c565ae48b97a2 (patch)
treef43fc647bdfabb522bdef32e21ea4a36404cc311 /setup.py
parent83b1d4e0e0490e5be05943da459c925a3ee3ff14 (diff)
parentffb95a1db742d71d7671f9e9c6db552774bb0ead (diff)
downloadmitmproxy-4952643a0d76eb1e9bd51cbbe95c565ae48b97a2.tar.gz
mitmproxy-4952643a0d76eb1e9bd51cbbe95c565ae48b97a2.tar.bz2
mitmproxy-4952643a0d76eb1e9bd51cbbe95c565ae48b97a2.zip
Merge remote-tracking branch 'base/master'
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 12 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index d6983d4f..79398a18 100644
--- a/setup.py
+++ b/setup.py
@@ -16,13 +16,12 @@ if os.name != "nt":
scripts.append("mitmproxy")
deps = {
- "netlib>=%s" % version.MINORVERSION,
+ "netlib>=%s, <%s" % (version.MINORVERSION, version.NEXT_MINORVERSION),
"pyasn1>0.1.2",
- "requests>=2.4.0",
"pyOpenSSL>=0.14",
"Flask>=0.10.1",
"tornado>=4.0.2",
- "sortedcontainers>=0.9.1"
+ "configargparse>=0.9.3"
}
script_deps = {
"mitmproxy": {
@@ -37,10 +36,6 @@ for script in scripts:
if os.name == "nt":
deps.add("pydivert>=0.0.4") # Transparent proxying on Windows
-console_scripts = [
- "%s = libmproxy.main:%s" % (s, s) for s in scripts
-]
-
setup(
name="mitmproxy",
@@ -67,14 +62,9 @@ setup(
"Topic :: Internet :: Proxy Servers",
"Topic :: Software Development :: Testing"
],
-
packages=find_packages(),
include_package_data=True,
-
- entry_points={
- 'console_scripts': console_scripts
- },
-
+ scripts = scripts,
install_requires=list(deps),
extras_require={
'dev': [
@@ -82,12 +72,19 @@ setup(
"nose>=1.3.0",
"nose-cov>=1.6",
"coveralls>=0.4.1",
- "pathod>=%s" % version.MINORVERSION
+ "pathod>=%s, <%s" % (
+ version.MINORVERSION, version.NEXT_MINORVERSION
+ )
],
'contentviews': [
"pyamf>=0.6.1",
"protobuf>=2.5.0",
"cssutils>=1.0"
+ ],
+ 'examples': [
+ "pytz",
+ "harparser",
+ "beautifulsoup4"
]
}
-) \ No newline at end of file
+)