diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2014-11-08 00:56:09 -0300 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2014-11-08 00:56:09 -0300 |
commit | d3bdbdbdeedda6031cd23adee8bd530f4bcb5c7b (patch) | |
tree | 2ad3c2c0baef3573ad8053c4b23ef62a1715d0fd /setup.py | |
parent | 29493c9c1029c43b24adaef69731e9668a321dc0 (diff) | |
parent | 6f21499d82d17c8655e77b8c771811d1d1d4353d (diff) | |
download | cryptography-d3bdbdbdeedda6031cd23adee8bd530f4bcb5c7b.tar.gz cryptography-d3bdbdbdeedda6031cd23adee8bd530f4bcb5c7b.tar.bz2 cryptography-d3bdbdbdeedda6031cd23adee8bd530f4bcb5c7b.zip |
Merge pull request #1467 from dstufft/no-implicit-compile
Refactor to avoid the implicit compile when executing setup.py
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -83,12 +83,12 @@ def get_ext_modules(): from cryptography.hazmat.primitives import constant_time, padding ext_modules = [ - OpenSSLBinding().ffi.verifier.get_extension(), + OpenSSLBinding.ffi.verifier.get_extension(), constant_time._ffi.verifier.get_extension(), padding._ffi.verifier.get_extension() ] if cc_is_available(): - ext_modules.append(CommonCryptoBinding().ffi.verifier.get_extension()) + ext_modules.append(CommonCryptoBinding.ffi.verifier.get_extension()) return ext_modules |