diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2015-08-20 15:14:49 -0400 |
---|---|---|
committer | Alex Gaynor <alex.gaynor@gmail.com> | 2015-08-20 15:14:49 -0400 |
commit | c12acccca5608033be30a04a197d234e2233220c (patch) | |
tree | 473708f34858be5dc0535b202fde25c54e305436 /setup.py | |
parent | 7e6ac3c8587cb1f79b62ca9049befe8e39e868a0 (diff) | |
parent | 7d17cbb8ec06b74860fe3f2a7a08ff116cc5692c (diff) | |
download | cryptography-c12acccca5608033be30a04a197d234e2233220c.tar.gz cryptography-c12acccca5608033be30a04a197d234e2233220c.tar.bz2 cryptography-c12acccca5608033be30a04a197d234e2233220c.zip |
Merge pull request #2285 from reaperhulk/pypy-error
raise an error if trying to install on PyPy < 2.6
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -45,7 +45,13 @@ if sys.version_info < (3, 4): if sys.version_info < (3, 3): requirements.append("ipaddress") -if platform.python_implementation() != "PyPy": +if platform.python_implementation() == "PyPy": + if sys.pypy_version_info < (2, 6): + raise RuntimeError( + "cryptography 1.0 is not compatible with PyPy < 2.6. Please " + "upgrade PyPy to use this library." + ) +else: requirements.append("cffi>=1.1.0") setup_requirements.append("cffi>=1.1.0") |