diff options
author | Paul Kehrer <paul.l.kehrer@gmail.com> | 2015-04-13 17:46:48 -0400 |
---|---|---|
committer | Paul Kehrer <paul.l.kehrer@gmail.com> | 2015-04-13 17:46:48 -0400 |
commit | 1bfc925dd91c8bac80d585be6e25fb8dee16b228 (patch) | |
tree | 8c47f8686aabf5b22c4b695cce3c35f8765c33f8 /setup.py | |
parent | 71485692f6efc63c53d267c4bb2bec756c10a7ae (diff) | |
parent | 2119f745959b8a5402df68a9b2f3342f1fe8eb6a (diff) | |
download | cryptography-1bfc925dd91c8bac80d585be6e25fb8dee16b228.tar.gz cryptography-1bfc925dd91c8bac80d585be6e25fb8dee16b228.tar.bz2 cryptography-1bfc925dd91c8bac80d585be6e25fb8dee16b228.zip |
Merge pull request #1840 from alex/simplify-setup
Simplify setup.py slightly
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 3 insertions, 6 deletions
@@ -29,22 +29,19 @@ with open(os.path.join(src_dir, "cryptography", "__about__.py")) as f: exec(f.read(), about) -SETUPTOOLS_DEPENDENCY = "setuptools" -CFFI_DEPENDENCY = "cffi>=0.8" -SIX_DEPENDENCY = "six>=1.4.1" VECTORS_DEPENDENCY = "cryptography_vectors=={0}".format(about['__version__']) requirements = [ "pyasn1", - SIX_DEPENDENCY, - SETUPTOOLS_DEPENDENCY + "six>=1.4.1", + "setuptools" ] if sys.version_info < (3, 4): requirements.append("enum34") if platform.python_implementation() != "PyPy": - requirements.append(CFFI_DEPENDENCY) + requirements.append("cffi>=0.8") # If you add a new dep here you probably need to add it in the tox.ini as well test_requirements = [ |