aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2013-08-11 14:33:29 -0700
committerAlex Gaynor <alex.gaynor@gmail.com>2013-08-11 14:33:29 -0700
commit09f53578923c241fbb76c0be6bdf725f3b96f528 (patch)
tree23c74b523af0245b6f0ca439363cb91b2f3f1910 /setup.py
parente61e5b704457cdb36034aff0d904e4b2dff95b0b (diff)
parent4c1852c74bc77ad82f198245a79cbcb75c832072 (diff)
downloadcryptography-09f53578923c241fbb76c0be6bdf725f3b96f528.tar.gz
cryptography-09f53578923c241fbb76c0be6bdf725f3b96f528.tar.bz2
cryptography-09f53578923c241fbb76c0be6bdf725f3b96f528.zip
Merge pull request #41 from dstufft/fix-setup
Fix setup
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py43
1 files changed, 34 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index fe23f302..e1cc2394 100644
--- a/setup.py
+++ b/setup.py
@@ -10,18 +10,35 @@
# implied.
# See the License for the specific language governing permissions and
# limitations under the License.
+from setuptools import setup, find_packages
+
+about = {}
+with open("cryptography/__about__.py") as fp:
+ exec(fp.read(), about)
+
+
+CFFI_DEPENDENCY = "cffi>=0.6"
+
+install_requires = [
+ CFFI_DEPENDENCY,
+]
+
+setup_requires = [
+ CFFI_DEPENDENCY,
+]
-from setuptools import setup
setup(
- name="cryptography",
- description="cryptography is a package designed to expose cryptographic "
- "primitives and recipes to Python developers.",
- license="Apache License, Version 2.0",
- url="https://github.com/alex/cryptography",
- # for cffi
- zip_safe=False,
- setup_requires=["cffi>=0.6"],
+ name=about["__title__"],
+ version=about["__version__"],
+
+ description=about["__summary__"],
+ license=about["__license__"],
+ url=about["__uri__"],
+
+ author=about["__author__"],
+ author_email=about["__email__"],
+
classifiers=[
"Development Status :: 2 - Pre-Alpha",
"Intended Audience :: Developers",
@@ -44,4 +61,12 @@ setup(
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Security :: Cryptography",
],
+
+ packages=find_packages(exclude=["tests", "tests.*"]),
+
+ install_requires=install_requires,
+ setup_requires=setup_requires,
+
+ # for cffi
+ zip_safe=False,
)