aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/ramdisk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/xm-test/ramdisk/Makefile.am')
-rw-r--r--tools/xm-test/ramdisk/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tools/xm-test/ramdisk/Makefile.am b/tools/xm-test/ramdisk/Makefile.am
index 4a4c7e65cf..8386218ff3 100644
--- a/tools/xm-test/ramdisk/Makefile.am
+++ b/tools/xm-test/ramdisk/Makefile.am
@@ -106,6 +106,15 @@ existing:
echo Error, $(XMTEST_VER_IMG) not found; \
false; \
fi
+# The newer linux kernels have ext2 disabled by default - but the
+# initrd is ext2.
+# The whole xm-test environment assumes, that the guest system uses
+# the same kernel as the dom0. Therefore the current (dom0's) kernel
+# is checked if ext2 is supported. If not (and ext3 is supported) the
+# initrd will be converted to ext3.
+ @cat /proc/filesystems | grep -q ext2 && \
+ cat /proc/filesystems | grep -q ext3 || \
+ /sbin/tune2fs -j $(XMTEST_DL_IMG) >/dev/null || true
clean-local: am_config_clean-local