aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 1b4625a299..9b05478083 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -60,6 +60,22 @@ AX_ARG_DEFAULT_ENABLE([debug], [Disable debug build of tools])
AX_ARG_DEFAULT_ENABLE([xend], [Disable xend toolstack])
AX_ARG_DEFAULT_DISABLE([blktap1], [Disable blktap1 tools])
+AC_ARG_ENABLE([qemu-traditional],
+ AS_HELP_STRING([--enable-qemu-traditional],
+ [Enable qemu traditional device model, (DEFAULT is on for x86, otherwise off)]),,[
+ case "$host_cpu" in
+ i[[3456]]86|x86_64)
+ enable_qemu_traditional="yes";;
+ *) enable_qemu_traditional="no";;
+ esac
+])
+AS_IF([test "x$enable_qemu_traditional" = "xyes"], [
+AC_DEFINE([HAVE_QEMU_TRADITIONAL], [1], [Qemu traditional enabled])
+ qemu_traditional=y],[
+ qemu_traditional=n
+])
+AC_SUBST(qemu_traditional)
+
AC_ARG_VAR([PREPEND_INCLUDES],
[List of include folders to prepend to CFLAGS (without -I)])
AC_ARG_VAR([PREPEND_LIB],