aboutsummaryrefslogtreecommitdiffstats
path: root/stubdom/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'stubdom/configure.ac')
-rw-r--r--stubdom/configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/stubdom/configure.ac b/stubdom/configure.ac
index 90fc94f591..6468203b63 100644
--- a/stubdom/configure.ac
+++ b/stubdom/configure.ac
@@ -8,6 +8,8 @@ AC_CONFIG_SRCDIR([../extras/mini-os/kernel.c])
AC_CONFIG_FILES([../config/Stubdom.mk])
AC_CONFIG_AUX_DIR([../])
+AC_CANONICAL_HOST
+
# M4 Macro includes
m4_include([../m4/stubdom.m4])
m4_include([../m4/features.m4])
@@ -16,7 +18,7 @@ m4_include([../m4/depends.m4])
m4_include([../m4/fetcher.m4])
# Enable/disable stub domains
-AX_STUBDOM_DEFAULT_ENABLE([ioemu-stubdom], [ioemu])
+AX_STUBDOM_CONDITIONAL([ioemu-stubdom], [ioemu])
AX_STUBDOM_DEFAULT_DISABLE([c-stubdom], [c])
AX_STUBDOM_DEFAULT_DISABLE([caml-stubdom], [caml])
AX_STUBDOM_DEFAULT_ENABLE([pv-grub], [grub])
@@ -24,6 +26,25 @@ AX_STUBDOM_DEFAULT_ENABLE([xenstore-stubdom], [xenstore])
AX_STUBDOM_CONDITIONAL([vtpm-stubdom], [vtpm])
AX_STUBDOM_CONDITIONAL([vtpmmgr-stubdom], [vtpmmgr])
+AC_ARG_ENABLE([qemu-traditional],,,[
+ case "$host_cpu" in
+ i[[3456]]86|x86_64)
+ enable_qemu_traditional="yes";;
+ *) enable_qemu_traditional="no";;
+ esac
+])
+AS_IF([test "x$enable_qemu_traditional" = "xyes"], [
+ qemu_traditional=y],[
+ qemu_traditional=n
+])
+AS_IF([test "x$ioemu" = "x"], [
+ ioemu=$qemu_traditional
+])
+echo "x$ioemu$qemu_traditional"
+AS_IF([test "x$ioemu$qemu_traditional" = "xyn"], [
+ AC_MSG_ERROR(IOEMU stubdomain requires qemu-traditional)
+])
+
AX_ARG_DEFAULT_ENABLE([debug], [Disable debug build of stubdom])
AX_ARG_DEFAULT_ENABLE([extfiles], [Use xen extfiles repository for libraries])
@@ -55,6 +76,7 @@ AX_STUBDOM_AUTO_DEPENDS([vtpmmgr], [vtpm])
#Conditionally enable these stubdoms based on the presense of dependencies
AX_STUBDOM_CONDITIONAL_FINISH([vtpm-stubdom], [vtpm])
AX_STUBDOM_CONDITIONAL_FINISH([vtpmmgr-stubdom], [vtpmmgr])
+AX_STUBDOM_CONDITIONAL_FINISH([ioemu-stubdom], [ioemu])
AX_STUBDOM_FINISH
AC_OUTPUT()