aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorEwan Mellor <ewan@xensource.com>2007-02-01 14:41:58 +0000
committerEwan Mellor <ewan@xensource.com>2007-02-01 14:41:58 +0000
commitedb08a7488e85500f1b96e82965a99745e327f5d (patch)
tree60c524a4f55d5f08395777ee9c36860305842cb1 /tools/xm-test/configure.ac
parenta84714b11ccd74c59d1034cf709e14e05ace4601 (diff)
downloadxen-edb08a7488e85500f1b96e82965a99745e327f5d.tar.gz
xen-edb08a7488e85500f1b96e82965a99745e327f5d.tar.bz2
xen-edb08a7488e85500f1b96e82965a99745e327f5d.zip
Use the new xen-python-path to set PYTHONPATH, rather than trying to do it in
XmTestLib.__init__ (and getting it wrong). Signed-off-by: Ewan Mellor <ewan@xensource.com>
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index ffbf146f34..d3c651a250 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -11,10 +11,12 @@ AC_PROG_CC
#AC_PROG_INSTALL
AC_CHECK_PROG([LILO], lilo, lilo, "no", [$PATH])
+XEN_PYTHON_PATH=$(/usr/sbin/xen-python-path)
+
# Right now, we can assume that the lib/ directory
# is two levels above the tests
TESTLIB=../../lib
-TENV="PYTHONPATH=$PYTHONPATH:$TESTLIB"
+TENV="PYTHONPATH=$PYTHONPATH:$TESTLIB:$XEN_PYTHON_PATH"
AC_ARG_ENABLE(hvm-support,
[[ --enable-hvm-support enable hardware virtual machine assist]],