aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorkaf24@firebug.cl.cam.ac.uk <kaf24@firebug.cl.cam.ac.uk>2006-01-29 10:55:28 +0100
committerkaf24@firebug.cl.cam.ac.uk <kaf24@firebug.cl.cam.ac.uk>2006-01-29 10:55:28 +0100
commite2f6e7621988388a5139a0a4e8a3509906be04ba (patch)
tree9dcb16bdeffaa02a78b46bc6dc6e2ad417b32fc6 /tools/xm-test/configure.ac
parent99957fb4c400c63513efccd4b0cbab27c1dabd9f (diff)
downloadxen-e2f6e7621988388a5139a0a4e8a3509906be04ba.tar.gz
xen-e2f6e7621988388a5139a0a4e8a3509906be04ba.tar.bz2
xen-e2f6e7621988388a5139a0a4e8a3509906be04ba.zip
Adding network testing support for xm-test with hvm.
1) Added capability for create_disk_image script to copy pcnet32 driver to disk.img. Added new cmdline option so can specify driver directory. 2) Added configuration --with-driver-dir=DVRDIR option so can specify where driver is at configure time. "builtin" keyword lets specify that driver is built into kernel. 3) Updated Makefile.am to build with new options. 4) Updated README to reflect changes. Signed-off-by: Daniel Stekloff <dsteklof@us.ibm.com>
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index 30f4fd348d..8f844c1148 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -46,6 +46,14 @@ AC_ARG_WITH(vmx-kernel,
dnl substitute @VMXKERNEL@ in all Makefiles
AC_SUBST(VMXKERNEL)
+AC_ARG_WITH(driver-dir,
+ [[ --with-driver-dir=drvdir Look in this directory for the pcnet32 driver for the vmx disk.img. drvdir can equal key word "builtin" if driver is built into the kernel]],
+ DRVDIR=$withval,
+ DRVDIR="no")
+
+dnl substitute @DRVDIR@ in all Makefiles
+AC_SUBST(DRVDIR)
+
AC_SUBST(TENV)
AC_SUBST(PACKAGE_VERSION)