aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorkfraser@localhost.localdomain <kfraser@localhost.localdomain>2006-10-18 16:07:55 +0100
committerkfraser@localhost.localdomain <kfraser@localhost.localdomain>2006-10-18 16:07:55 +0100
commitb77b89e80e3194eb162d1f42c747b8fd10374985 (patch)
tree05474062695e55a6d6ccc0a61d654f2df8069d53 /tools/xm-test/configure.ac
parentee89b4ab594e3027c04052108ea8b494750fe26c (diff)
downloadxen-b77b89e80e3194eb162d1f42c747b8fd10374985.tar.gz
xen-b77b89e80e3194eb162d1f42c747b8fd10374985.tar.bz2
xen-b77b89e80e3194eb162d1f42c747b8fd10374985.zip
[TPM] Add tests cases for the ACM security hooks and tools to
the xm test suite. The tests can be run with ACM turned off (not compiled into Xen; see user doc for this), but most of them will be skipped then. They can be run with a command like make -C tests/security-acm check-TESTS from the xm-test directory. They are also part of the default tests in the tests suite and part of a new group test 'security'. Since some of the tests require resources to be labeled, one must explicitly enable the resources to be allowed to be labeled by the test suite by running ./configure --enable-full-labeling once. To turn it off, the '--enable-full-labeling' parameter should be omitted. Signed-off-by: Stefan Berger <stefanb@us.ibm.com>
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index 5183162f82..10091cc964 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -38,6 +38,20 @@ fi
AM_CONDITIONAL(HVM, test x$ENABLE_HVM = xTrue)
AC_SUBST(ENABLE_HVM)
+AC_ARG_ENABLE(full-labeling,
+ [[ --enable-full-labeling allows the test suite to label all resources]],
+ [
+ ENABLE_LABELING=True
+ ],[
+ ENABLE_LABELING=False
+ ])
+
+if test "x$ENABLE_LABELING" = "xTrue"; then
+ echo "ACM_LABEL_RESOURCES = True" > lib/XmTestLib/acm_config.py
+else
+ rm -f lib/XmTestLib/acm_config.py*
+fi
+
# Network needs to know ips to use: dhcp or a range of IPs in the form
# of: 192.168.1.1-192.168.1.100
# If not dhcp, a netmask and network address must be supplied. Defaults to
@@ -127,6 +141,7 @@ AC_CONFIG_FILES([
tests/restore/Makefile
tests/save/Makefile
tests/sched-credit/Makefile
+ tests/security-acm/Makefile
tests/sedf/Makefile
tests/shutdown/Makefile
tests/sysrq/Makefile