aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorKeir Fraser <keir.fraser@citrix.com>2008-01-17 15:13:40 +0000
committerKeir Fraser <keir.fraser@citrix.com>2008-01-17 15:13:40 +0000
commitaac518b954d087cd64e7466cda087720280d592b (patch)
tree26dcab5e5ca0da9835138fb3d9f0b1a8d0e49054 /tools/xm-test/configure.ac
parent5564364efa48fff512edf2210d6dd71fb72a5e52 (diff)
downloadxen-aac518b954d087cd64e7466cda087720280d592b.tar.gz
xen-aac518b954d087cd64e7466cda087720280d592b.tar.bz2
xen-aac518b954d087cd64e7466cda087720280d592b.zip
tools/docs: Fix example and default IP addresses.
In various places in documentation and code, IP addresses are provided as examples, defaults, or dummy configuration. In general the specific IP addresses used in Xen are not always appropriate. (For example, 1.2.3.4 is used in a few places!) The following addresses should be used: * For examples and documentation, 192.0.2.0/24. (See RFC3330.) * For defaults for private networks, a random network from RFC1918. I have randomly selected 172.30.206.0/24 for this purpose and documented this in at the only registry I know of, www.ucam.org/cam-grin. This network should henceforth be used for default configurations of local bridges, test networks, etc. in Xen tools. The following addresses should NOT be used: * 10.0.*.*, 10.1.*.*, 192.168.0.*, 192.168.1.*, etc. Using these addresses gives greatly increased likelihood of collision, as ignorant network administrators and reckless middlebox vendors often pick networks from the bottom of 10/8 and 192.168/16. * 169.254.*.*. These are reserved for zeroconf (ad-hoc networking) and should not be used for Xen private networks, bridges, etc., etc. Use of these addresses by Xen scripts causes trouble on hosts (eg laptops) which find themselves in ad-hoc networking environments. I think this is not hypothetical (!) since at least one Linux distribution have specific code to detect this case and cause Xen startup to fail iff the host already has an external zeroconf address. * 1.2.3.4. WTF !? I have also used 127.0.255.255 in one place where apparently a dummy address is needed (some Linux kernels won't accept a lack of an NFS server address). If 127.0.255.255 is mistakenly used it is unlikely to do any damage to real traffic even if it does escape into the network at large. Signed-off-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index bbc639bdb0..a92b6daa6b 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -56,24 +56,24 @@ else
fi
# Network needs to know ips to use: dhcp or a range of IPs in the form
-# of: 192.168.1.1-192.168.1.100
+# of: 192.0.2.1-192.0.2.100
# If not dhcp, a netmask and network address must be supplied. Defaults to
-# zeroconf range.
-NET_IP_RANGE="169.254.0.1-169.254.255.255"
+# range allocated in www.ucam.org/cam-grin.
+NET_IP_RANGE="172.30.206.1-172.30.206.254"
AC_ARG_WITH(net-ip-range,
- [ --with-net-ip-range=ip-range Set a range of ip addresses to use for xm-test guest domain networks. Can specify dhcp or a range of IPs: 192.168.1.1-192.168.1.100 [[default="169.254.0.1-169.254.255.255"]]],
+ [ --with-net-ip-range=ip-range Set a range of ip addresses to use for xm-test guest domain networks. Can specify dhcp or a range of IPs: 192.0.2.1-192.0.2.100 [[default="172.30.206.1-172.30.206.254"]]],
[ NET_IP_RANGE="$withval" ])
iprange=`echo $NET_IP_RANGE | perl -e 'while(<>) { print if /\d+\.\d+\.\d+\.\d+-\d+\.\d+\.\d+\.\d+/ }'`
-NETWORK_ADDRESS="169.254.0.0"
+NETWORK_ADDRESS="172.30.206.0"
AC_ARG_WITH(network-address,
- [ --with-network-address=ip Set network address to use with ip range [[default="169.254.0.0"]]],
+ [ --with-network-address=ip Set network address to use with ip range [[default="172.30.206.0"]]],
[ NETWORK_ADDRESS="$withval" ])
-NETMASK="255.255.0.0"
+NETMASK="255.255.255.0"
AC_ARG_WITH(netmask,
- [ --with-netmask=mask Set netmask to use with ip range [[default="255.255.0.0"]]],
+ [ --with-netmask=mask Set netmask to use with ip range [[default="255.255.255.0"]]],
[ NETMASK="$withval" ])
if test "x$NET_IP_RANGE" != "xdhcp" && test -z "$iprange"