aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorJames Bulpin <james@xensource.com>2007-08-12 16:09:13 +0100
committerJames Bulpin <james@xensource.com>2007-08-12 16:09:13 +0100
commit9119ea5153b5feb9aee3ce8d66f909f529f443e9 (patch)
tree09c3cc725ebb50a296c7fa5d6fcbfae697fd46c8 /tools/xm-test/configure.ac
parent0067e950074566bfc542ce3cf640c4546217d915 (diff)
downloadxen-9119ea5153b5feb9aee3ce8d66f909f529f443e9.tar.gz
xen-9119ea5153b5feb9aee3ce8d66f909f529f443e9.tar.bz2
xen-9119ea5153b5feb9aee3ce8d66f909f529f443e9.zip
xm-test: Allow dom0 network interface used in tests to be overriden
./configure --with-dom0-intf=<intf> (default vif0.0)
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index d3c651a250..14aee142b7 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -85,6 +85,13 @@ AC_SUBST(NET_IP_RANGE)
AC_SUBST(NETWORK_ADDRESS)
AC_SUBST(NETMASK)
+DOM0_INTF="vif0.0"
+AC_ARG_WITH(dom0-intf,
+ [ --with-dom0-intf=intf Set dom0 interface name [[default="vif0.0"]]],
+ [ DOM0_INTF="$withval" ])
+
+AC_SUBST(DOM0_INTF)
+
AC_ARG_WITH(hvm-kernel,
[[ --with-hvm-kernel=kernel Use this kernel for hvm disk.img testing]],
HVMKERNEL=$withval,