aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorstekloff@elm3b216.beaverton.ibm.com <stekloff@elm3b216.beaverton.ibm.com>2006-01-24 17:59:33 +0100
committerstekloff@elm3b216.beaverton.ibm.com <stekloff@elm3b216.beaverton.ibm.com>2006-01-24 17:59:33 +0100
commit32553461c76a016aea6435a86a1d60152be995fa (patch)
treee0a1947d1fba03af5738e23c878dc9ba721af4e6 /tools/xm-test/configure.ac
parent33098e7fc421bc77dba7506366a627abe700aab0 (diff)
downloadxen-32553461c76a016aea6435a86a1d60152be995fa.tar.gz
xen-32553461c76a016aea6435a86a1d60152be995fa.tar.bz2
xen-32553461c76a016aea6435a86a1d60152be995fa.zip
Added dependency check for lilo in configure.ac for vmx enabled builds. Must
have lilo version 22.7 or greater. Signed-off-by: Daniel Stekloff <dsteklof@us.ibm.com>
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index 4a606e611c..f61e6284cb 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -7,6 +7,7 @@ AM_INIT_AUTOMAKE([1.7 foreign])
# Check for dependencies
AC_PROG_CC
#AC_PROG_INSTALL
+AC_CHECK_PROG([LILO], lilo, lilo, "no", [$PATH])
# Right now, we can assume that the lib/ and ramdisk/ directories
# are two levels above the tests
@@ -22,6 +23,18 @@ AC_ARG_ENABLE(vmx-support,
ENABLE_VMX=False
])
+if test "x$ENABLE_VMX" = "xTrue"; then
+ if test "$LILO" = "no"; then
+ AC_MSG_ERROR([lilo not found
+lilo version 22.7 or greater must be installed for testing with vmx enabled.])
+ else
+ pass=`$LILO -V | sed -e "s/LILO version //" | awk -F "." '{if ($1 >=22 && $2 >= 7) print "true"; else print "false"}'`
+ if test "$pass" != "true"; then
+ AC_MSG_ERROR(Lilo version must be equal or greater to 22.7+.)
+ fi
+ fi
+fi
+
AM_CONDITIONAL(VMX, test x$ENABLE_VMX = xTrue)
AC_SUBST(ENABLE_VMX)