aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/configure.ac
diff options
context:
space:
mode:
authorstekloff@elm3b216.beaverton.ibm.com <stekloff@elm3b216.beaverton.ibm.com>2006-01-26 00:06:39 +0100
committerstekloff@elm3b216.beaverton.ibm.com <stekloff@elm3b216.beaverton.ibm.com>2006-01-26 00:06:39 +0100
commit0c3ce14ba123e8c3c97e8583f74d78a690212ddf (patch)
tree31646fc78ced3c6b63adff6b456b830227fe175e /tools/xm-test/configure.ac
parent606c67c6c9e132811d9613769dc35548c8b75cd3 (diff)
downloadxen-0c3ce14ba123e8c3c97e8583f74d78a690212ddf.tar.gz
xen-0c3ce14ba123e8c3c97e8583f74d78a690212ddf.tar.bz2
xen-0c3ce14ba123e8c3c97e8583f74d78a690212ddf.zip
Add configuration option for specifying kernel to use for hvm/vmx testing
in xm-test. Added --with-vmx-kernel=KERNEL. Signed-off-by: Daniel Stekloff <dsteklof@us.ibm.com>
Diffstat (limited to 'tools/xm-test/configure.ac')
-rw-r--r--tools/xm-test/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/xm-test/configure.ac b/tools/xm-test/configure.ac
index f61e6284cb..013ee27354 100644
--- a/tools/xm-test/configure.ac
+++ b/tools/xm-test/configure.ac
@@ -38,6 +38,14 @@ fi
AM_CONDITIONAL(VMX, test x$ENABLE_VMX = xTrue)
AC_SUBST(ENABLE_VMX)
+AC_ARG_WITH(vmx-kernel,
+ [[ --with-vmx-kernel=kernel Use this kernel for vmx disk.img testing]],
+ VMXKERNEL=$withval,
+ VMXKERNEL="no")
+
+dnl substitute @VMXKERNEL@ in all Makefiles
+AC_SUBST(VMXKERNEL)
+
AC_SUBST(TENV)
AC_SUBST(PACKAGE_VERSION)