aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xm-test/Makefile.am
diff options
context:
space:
mode:
authoremellor@leeni.uk.xensource.com <emellor@leeni.uk.xensource.com>2005-11-07 12:36:16 +0100
committeremellor@leeni.uk.xensource.com <emellor@leeni.uk.xensource.com>2005-11-07 12:36:16 +0100
commit3ec891fe7b48750d20f1fbf425d155487c0fa0c8 (patch)
tree23bcedcbfda1412c6da5ee4f355820856ba64605 /tools/xm-test/Makefile.am
parent27be16e320fac3b64bb579102f065fbf7ee22b1f (diff)
downloadxen-3ec891fe7b48750d20f1fbf425d155487c0fa0c8.tar.gz
xen-3ec891fe7b48750d20f1fbf425d155487c0fa0c8.tar.bz2
xen-3ec891fe7b48750d20f1fbf425d155487c0fa0c8.zip
Wholesale import of xm-test 0.4.0.
This is not yet integrated with the rest of the Xen build system. Signed-off-by: Ewan Mellor <ewan@xensource.com>
Diffstat (limited to 'tools/xm-test/Makefile.am')
-rw-r--r--tools/xm-test/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/xm-test/Makefile.am b/tools/xm-test/Makefile.am
new file mode 100644
index 0000000000..a065616ece
--- /dev/null
+++ b/tools/xm-test/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = ramdisk tests
+EXTRA_DIST = lib runtest.sh mkreport
+
+# Remove any pyc's, CVS dirs, and prune the skel dirs
+dist-hook:
+ find $(distdir) -name '*~' -delete -print
+ find $(distdir) -name '*.pyc' -delete -print
+ for i in Root Repository Entries; do \
+ find $(distdir) -name $$i -delete ;\
+ done
+ find $(distdir) -name CVS -delete
+ find $(distdir) -name '*.test' -delete
+ cd $(distdir)/ramdisk/skel && find . -empty -delete
+ chmod a+x $(distdir)/runtest.sh
+