aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xend/setup.py
diff options
context:
space:
mode:
authorkaf24@scramble.cl.cam.ac.uk <kaf24@scramble.cl.cam.ac.uk>2004-03-14 18:23:01 +0000
committerkaf24@scramble.cl.cam.ac.uk <kaf24@scramble.cl.cam.ac.uk>2004-03-14 18:23:01 +0000
commit0b9d367cf8677be6d54c6d80e393499c99398d2f (patch)
tree2ad2fcb1368dd2fde113ea96c85b00be135dd1e5 /tools/xend/setup.py
parenteefca814b7257774ff8a606b88155cbfa17af89b (diff)
downloadxen-0b9d367cf8677be6d54c6d80e393499c99398d2f.tar.gz
xen-0b9d367cf8677be6d54c6d80e393499c99398d2f.tar.bz2
xen-0b9d367cf8677be6d54c6d80e393499c99398d2f.zip
bitkeeper revision 1.795 (4054a3055ggg3MJTpSU1-ZFQRfQQ5g)
xend.py, setup.py: new file Many files: Rewritten the Xen control daemon in Python, with C extensions for the low-level bits. All our Python libraries now throw exceptions on error rather than returning error codes --- this will require our higher-level scripts to be updated at some point.
Diffstat (limited to 'tools/xend/setup.py')
-rw-r--r--tools/xend/setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/xend/setup.py b/tools/xend/setup.py
new file mode 100644
index 0000000000..9bc967785f
--- /dev/null
+++ b/tools/xend/setup.py
@@ -0,0 +1,11 @@
+
+from distutils.core import setup, Extension
+
+module = Extension("xend_utils",
+ include_dirs = ["../xc/lib",
+ "../../xenolinux-sparse/include"],
+ library_dirs = ["../xc/lib"],
+ libraries = ["xc"],
+ sources = ["xend_utils.c"])
+
+setup(name = "xend_utils", version = "1.0", ext_modules = [module])