aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorsmh22@firebug.cl.cam.ac.uk <smh22@firebug.cl.cam.ac.uk>2006-04-24 10:58:25 +0100
committersmh22@firebug.cl.cam.ac.uk <smh22@firebug.cl.cam.ac.uk>2006-04-24 10:58:25 +0100
commite7f4f3a1de128df30cc2c8380e2e7ac039c05ebf (patch)
tree88bb8c2b7080abb5946dc93f041907f78997f969 /tools/python/setup.py
parent2d59e34fc28f8e7ed22c025ad45683ed244a62f6 (diff)
downloadxen-e7f4f3a1de128df30cc2c8380e2e7ac039c05ebf.tar.gz
xen-e7f4f3a1de128df30cc2c8380e2e7ac039c05ebf.tar.bz2
xen-e7f4f3a1de128df30cc2c8380e2e7ac039c05ebf.zip
This patch adds new python access control management scripts, which
integrate into Xen Management and which support the new access control labels (labels replace the ssidref numbers at the management user interface). Signed-off by: Reiner Sailer <sailer@us.ibm.com>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 49f79e1b87..640dcef000 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -31,6 +31,13 @@ xs = Extension("xs",
libraries = libraries,
sources = [ "xen/lowlevel/xs/xs.c" ])
+acm = Extension("acm",
+ extra_compile_args = extra_compile_args,
+ include_dirs = include_dirs + [ "xen/lowlevel/acm" ],
+ library_dirs = library_dirs,
+ libraries = libraries,
+ sources = [ "xen/lowlevel/acm/acm.c" ])
+
setup(name = 'xen',
version = '3.0',
description = 'Xen',
@@ -50,7 +57,7 @@ setup(name = 'xen',
'xen.xm.tests'
],
ext_package = "xen.lowlevel",
- ext_modules = [ xc, xs ]
+ ext_modules = [ xc, xs, acm ]
)
os.chdir('logging')