aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorkfraser@localhost.localdomain <kfraser@localhost.localdomain>2007-03-05 18:54:26 +0000
committerkfraser@localhost.localdomain <kfraser@localhost.localdomain>2007-03-05 18:54:26 +0000
commitd7ee1f5383acc25010251a9943dcd2485d60452a (patch)
tree4fa8e6d127e13d0eb35f21ca3ae6f7adcd8e196d /tools/python/setup.py
parentfb4f0a04214ab47b3eff2d05f0e0cfe33d7e00c5 (diff)
downloadxen-d7ee1f5383acc25010251a9943dcd2485d60452a.tar.gz
xen-d7ee1f5383acc25010251a9943dcd2485d60452a.tar.bz2
xen-d7ee1f5383acc25010251a9943dcd2485d60452a.zip
Move ptsname module under tools/python.
Signed-off-by: Keir Fraser <keir@xensource.com>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 7b25025d9d..11ef487203 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -44,7 +44,14 @@ acm = Extension("acm",
libraries = libraries,
sources = [ "xen/lowlevel/acm/acm.c" ])
-modules = [ xc, xs, acm ]
+ptsname = Extension("ptsname",
+ extra_compile_args = extra_compile_args,
+ include_dirs = include_dirs + [ "ptsname" ],
+ library_dirs = library_dirs,
+ libraries = libraries,
+ sources = [ "ptsname/ptsname.c" ])
+
+modules = [ xc, xs, acm, ptsname ]
if os.uname()[0] == 'SunOS':
modules.append(scf)