aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorcl349@firebug.cl.cam.ac.uk <cl349@firebug.cl.cam.ac.uk>2005-09-07 18:37:55 +0000
committercl349@firebug.cl.cam.ac.uk <cl349@firebug.cl.cam.ac.uk>2005-09-07 18:37:55 +0000
commitc3c71f3f6a6164a59568cb3265fc10af4f8fa04c (patch)
tree31f3b91a2d786a204c2fd4631e24062919588b1d /tools/python/setup.py
parent78552ee77cf6bb2ed627de607d9ae3f5fffdc3bd (diff)
downloadxen-c3c71f3f6a6164a59568cb3265fc10af4f8fa04c.tar.gz
xen-c3c71f3f6a6164a59568cb3265fc10af4f8fa04c.tar.bz2
xen-c3c71f3f6a6164a59568cb3265fc10af4f8fa04c.zip
g/c unused xu extension.
Signed-off-by: Christian Limpach <Christian.Limpach@cl.cam.ac.uk>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py15
1 files changed, 3 insertions, 12 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 82ff6e1662..9ef25a2f99 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -7,10 +7,8 @@ XEN_ROOT = "../.."
extra_compile_args = [ "-fno-strict-aliasing", "-Wall", "-Werror" ]
-include_dirs = [ XEN_ROOT + "/tools/python/xen/lowlevel/xu",
- XEN_ROOT + "/tools/libxc",
+include_dirs = [ XEN_ROOT + "/tools/libxc",
XEN_ROOT + "/tools/xenstore",
- XEN_ROOT + "/tools/xcs",
]
library_dirs = [ XEN_ROOT + "/tools/libxc",
@@ -26,13 +24,6 @@ xc = Extension("xc",
libraries = libraries,
sources = [ "xen/lowlevel/xc/xc.c" ])
-xu = Extension("xu",
- extra_compile_args = extra_compile_args,
- include_dirs = include_dirs + [ "xen/lowlevel/xu" ],
- library_dirs = library_dirs,
- libraries = libraries,
- sources = [ "xen/lowlevel/xu/xu.c" ])
-
xs = Extension("xs",
extra_compile_args = extra_compile_args,
include_dirs = include_dirs + [ "xen/lowlevel/xs" ],
@@ -51,10 +42,10 @@ setup(name = 'xen',
'xen.xend.xenstore',
'xen.xm',
'xen.web',
- 'xen.sv'
+ 'xen.sv'
],
ext_package = "xen.lowlevel",
- ext_modules = [ xc, xu, xs ]
+ ext_modules = [ xc, xs ]
)
os.chdir('logging')