aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorkfraser@localhost.localdomain <kfraser@localhost.localdomain>2006-11-02 18:19:22 +0000
committerkfraser@localhost.localdomain <kfraser@localhost.localdomain>2006-11-02 18:19:22 +0000
commita034a6ad0ef17fbd1e48b8a92ec5271ce15f249f (patch)
treec1e52a16528338ab20f8dc3a32dbfe89795d8ff5 /tools/python/setup.py
parentaf7afdc2a162a22d81b3b82a9f8784062e784bc0 (diff)
downloadxen-a034a6ad0ef17fbd1e48b8a92ec5271ce15f249f.tar.gz
xen-a034a6ad0ef17fbd1e48b8a92ec5271ce15f249f.tar.bz2
xen-a034a6ad0ef17fbd1e48b8a92ec5271ce15f249f.zip
Dynamically link to libgcc on Solaris. Also clean up duplicate -Wall flags.
Signed-off-by: John Levon <john.levon@sun.com>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 640dcef000..56dd3e4a0b 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -4,8 +4,7 @@ import os
XEN_ROOT = "../.."
-extra_compile_args = [ "-fno-strict-aliasing", "-Wall", "-Werror" ]
-
+extra_compile_args = [ "-fno-strict-aliasing", "-Werror" ]
include_dirs = [ XEN_ROOT + "/tools/libxc",
XEN_ROOT + "/tools/xenstore",