aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorkfraser@localhost.localdomain <kfraser@localhost.localdomain>2007-08-31 16:50:26 +0100
committerkfraser@localhost.localdomain <kfraser@localhost.localdomain>2007-08-31 16:50:26 +0100
commit87a39e42b82c867e81b5687cef4ec8f2f090f417 (patch)
tree5e43d1fd9d4a0df2046c7d25a5d2c85ffc0fb75d /tools/python/setup.py
parent6680dbcb4f587b38220b0f1fe0d10ef5ddd9546a (diff)
downloadxen-87a39e42b82c867e81b5687cef4ec8f2f090f417.tar.gz
xen-87a39e42b82c867e81b5687cef4ec8f2f090f417.tar.bz2
xen-87a39e42b82c867e81b5687cef4ec8f2f090f417.zip
xend: Always build lowlevel security modules, as there are some
dependencies on these from with xend proper. Signed-off-by: Keir Fraser <keir@xensource.com>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 0b55ce7543..25c87c3b91 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -59,15 +59,10 @@ ptsname = Extension("ptsname",
libraries = libraries,
sources = [ "ptsname/ptsname.c" ])
-modules = [ xc, xs, ptsname ]
+modules = [ xc, xs, ptsname, acm, flask ]
if os.uname()[0] == 'SunOS':
modules.append(scf)
-if os.environ.get('XEN_SECURITY_MODULE') == 'acm':
- modules.append(acm)
-if os.environ.get('XEN_SECURITY_MODULE') == 'flask':
- modules.append(flask)
-
setup(name = 'xen',
version = '3.0',
description = 'Xen',