aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authorEwan Mellor <ewan@xensource.com>2007-01-18 15:07:51 +0000
committerEwan Mellor <ewan@xensource.com>2007-01-18 15:07:51 +0000
commit674fb7f63e1b90eb6fd8145ca51c5f45b845f835 (patch)
tree50804bad6d47547858bdf0133f0ff365f4a2674a /tools/python/setup.py
parent2dd9828c75750d08c6b7a792b54035fcf6ca74e0 (diff)
downloadxen-674fb7f63e1b90eb6fd8145ca51c5f45b845f835.tar.gz
xen-674fb7f63e1b90eb6fd8145ca51c5f45b845f835.tar.bz2
xen-674fb7f63e1b90eb6fd8145ca51c5f45b845f835.zip
Allow xend configuration via Solaris SMF as well as the config file.
Signed-off-by: John Levon <john.levon@sun.com>
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 56dd3e4a0b..7b25025d9d 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -30,6 +30,13 @@ xs = Extension("xs",
libraries = libraries,
sources = [ "xen/lowlevel/xs/xs.c" ])
+scf = Extension("scf",
+ extra_compile_args = extra_compile_args,
+ include_dirs = include_dirs + [ "xen/lowlevel/scf" ],
+ library_dirs = library_dirs,
+ libraries = libraries,
+ sources = [ "xen/lowlevel/scf/scf.c" ])
+
acm = Extension("acm",
extra_compile_args = extra_compile_args,
include_dirs = include_dirs + [ "xen/lowlevel/acm" ],
@@ -37,6 +44,10 @@ acm = Extension("acm",
libraries = libraries,
sources = [ "xen/lowlevel/acm/acm.c" ])
+modules = [ xc, xs, acm ]
+if os.uname()[0] == 'SunOS':
+ modules.append(scf)
+
setup(name = 'xen',
version = '3.0',
description = 'Xen',
@@ -56,7 +67,7 @@ setup(name = 'xen',
'xen.xm.tests'
],
ext_package = "xen.lowlevel",
- ext_modules = [ xc, xs, acm ]
+ ext_modules = modules
)
os.chdir('logging')