aboutsummaryrefslogtreecommitdiffstats
path: root/tools/python/setup.py
diff options
context:
space:
mode:
authormjw@wray-m-3.hpl.hp.com <mjw@wray-m-3.hpl.hp.com>2004-06-30 09:52:59 +0000
committermjw@wray-m-3.hpl.hp.com <mjw@wray-m-3.hpl.hp.com>2004-06-30 09:52:59 +0000
commit5d9ba6096cd2847852ce931d51e428cc3745b6b6 (patch)
tree5fa6d660317709d1958c3713c27dcfbccd851292 /tools/python/setup.py
parentf3425596749425d45eb7debae7901af24ac61138 (diff)
downloadxen-5d9ba6096cd2847852ce931d51e428cc3745b6b6.tar.gz
xen-5d9ba6096cd2847852ce931d51e428cc3745b6b6.tar.bz2
xen-5d9ba6096cd2847852ce931d51e428cc3745b6b6.zip
bitkeeper revision 1.1034 (40e28d7bx0XoTn2USwCDCvPvUTLZjQ)
Rename ext to lowlevel.
Diffstat (limited to 'tools/python/setup.py')
-rw-r--r--tools/python/setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/tools/python/setup.py b/tools/python/setup.py
index 0b8efce0fd..93e7cad00c 100644
--- a/tools/python/setup.py
+++ b/tools/python/setup.py
@@ -8,7 +8,7 @@ extra_compile_args = [ "-fno-strict-aliasing", "-Wall", "-Werror" ]
include_dirs = [ XEN_ROOT + "/xen/include/hypervisor-ifs",
XEN_ROOT + "/linux-xen-sparse/include",
- XEN_ROOT + "/tools/python/xen/ext/xu",
+ XEN_ROOT + "/tools/python/xen/lowlevel/xu",
XEN_ROOT + "/tools/libxc",
XEN_ROOT + "/tools/libxutil",
]
@@ -21,28 +21,28 @@ libraries = [ "xc", "xutil" ]
xc = Extension("xc",
extra_compile_args = extra_compile_args,
- include_dirs = include_dirs + [ "xen/ext/xc" ],
+ include_dirs = include_dirs + [ "xen/lowlevel/xc" ],
library_dirs = library_dirs,
libraries = libraries,
- sources = [ "xen/ext/xc/xc.c" ])
+ sources = [ "xen/lowlevel/xc/xc.c" ])
xu = Extension("xu",
extra_compile_args = extra_compile_args,
- include_dirs = include_dirs + [ "xen/ext/xu" ],
+ include_dirs = include_dirs + [ "xen/lowlevel/xu" ],
library_dirs = library_dirs,
libraries = libraries,
- sources = [ "xen/ext/xu/xu.c" ])
+ sources = [ "xen/lowlevel/xu/xu.c" ])
setup(name = 'xen',
version = '2.0',
description = 'Xen',
packages = ['xen',
- 'xen.ext',
+ 'xen.lowlevel',
'xen.util',
'xen.xend',
'xen.xend.server',
'xen.xm',
],
- ext_package = "xen.ext",
+ ext_package = "xen.lowlevel",
ext_modules = [ xc, xu ]
)