aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pygrub/setup.py
diff options
context:
space:
mode:
authorsmh22@firebug.cl.cam.ac.uk <smh22@firebug.cl.cam.ac.uk>2005-08-02 09:31:47 +0000
committersmh22@firebug.cl.cam.ac.uk <smh22@firebug.cl.cam.ac.uk>2005-08-02 09:31:47 +0000
commita89e4d770c0c2cece5c5cf4b1e93c8983a6b452f (patch)
tree9215562ed8f22806f61210e9b9562e4a8565ba60 /tools/pygrub/setup.py
parent8dbafbfdcc9ab62d14424bcc171025b1b4a936ca (diff)
downloadxen-a89e4d770c0c2cece5c5cf4b1e93c8983a6b452f.tar.gz
xen-a89e4d770c0c2cece5c5cf4b1e93c8983a6b452f.tar.bz2
xen-a89e4d770c0c2cece5c5cf4b1e93c8983a6b452f.zip
The attached patch adds the support that was only stubbed in to be able
to support having reading the boot loader config when you're using a whole disk (eg, file:/root/disk.img,xvda,w) as opposed to just a partition. This reads the partition table in the MBR to find the active partition and then passes that offset down into the filesystem reading code. Signed-off-by: Jeremy Katz <katzj@redhat.com>
Diffstat (limited to 'tools/pygrub/setup.py')
-rw-r--r--tools/pygrub/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/pygrub/setup.py b/tools/pygrub/setup.py
index b72ea38857..6b32346b06 100644
--- a/tools/pygrub/setup.py
+++ b/tools/pygrub/setup.py
@@ -23,7 +23,7 @@ if os.path.exists("/usr/include/reiserfs/reiserfs.h"):
fsys_pkgs.append("grub.fsys.reiser")
setup(name='pygrub',
- version='0.2',
+ version='0.3',
description='Boot loader that looks a lot like grub for Xen',
author='Jeremy Katz',
author_email='katzj@redhat.com',