aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pygrub/setup.py
diff options
context:
space:
mode:
authorkaf24@firebug.cl.cam.ac.uk <kaf24@firebug.cl.cam.ac.uk>2005-10-21 18:19:38 +0100
committerkaf24@firebug.cl.cam.ac.uk <kaf24@firebug.cl.cam.ac.uk>2005-10-21 18:19:38 +0100
commit7ebcb094f9f19f8230ac0d72c4b9c53d55ebb51b (patch)
tree25d607f82bc0e0b8e37facd05f1d4e759fa1f161 /tools/pygrub/setup.py
parent73e4aa4e2b844b0b53802348c0d26a7e7bda36c4 (diff)
downloadxen-7ebcb094f9f19f8230ac0d72c4b9c53d55ebb51b.tar.gz
xen-7ebcb094f9f19f8230ac0d72c4b9c53d55ebb51b.tar.bz2
xen-7ebcb094f9f19f8230ac0d72c4b9c53d55ebb51b.zip
Tweak to pygrub build config detection.
Signed-off-by: Jeremy Katz <katzj@redhat.com>
Diffstat (limited to 'tools/pygrub/setup.py')
-rw-r--r--tools/pygrub/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/pygrub/setup.py b/tools/pygrub/setup.py
index 43e46762a8..5e0937bbad 100644
--- a/tools/pygrub/setup.py
+++ b/tools/pygrub/setup.py
@@ -13,7 +13,7 @@ if os.path.exists("/usr/include/ext2fs/ext2_fs.h"):
cc = new_compiler()
cc.add_library("ext2fs")
try:
- if cc.has_function("ext2fs_open2"):
+ if hasattr(cc, "has_function") and cc.has_function("ext2fs_open2"):
ext2defines.append( ("HAVE_EXT2FS_OPEN2", None) )
else:
sys.stderr.write("WARNING: older version of e2fsprogs installed, not building full\n")