aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <Ian.Campbell@citrix.com>2012-08-31 11:13:49 +0100
committerIan Campbell <Ian.Campbell@citrix.com>2012-08-31 11:13:49 +0100
commitf185a527caf966e10538d342eb677ccc4875200c (patch)
tree6fe616279efd53e20b426ca0055ff952248d3b52 /tools/configure.ac
parent3c5b9dcac890323c43794684510c71ebc74501a2 (diff)
downloadxen-f185a527caf966e10538d342eb677ccc4875200c.tar.gz
xen-f185a527caf966e10538d342eb677ccc4875200c.tar.bz2
xen-f185a527caf966e10538d342eb677ccc4875200c.zip
tools: remove --disable-pythontools option
This incorrectly removes the $(PYTHON) variable which is used at build time as well as by the tools. Remove and revisit for 4.3. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac21
1 files changed, 9 insertions, 12 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index b41ba9ca71..703a24bf33 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -40,7 +40,6 @@ AX_ARG_DEFAULT_DISABLE([githttp], [Download GIT repositories via HTTP])
AX_ARG_DEFAULT_ENABLE([monitors], [Disable xenstat and xentop monitoring tools])
AX_ARG_DEFAULT_DISABLE([vtpm], [Enable Virtual Trusted Platform Module])
AX_ARG_DEFAULT_DISABLE([xenapi], [Enable Xen API Bindings])
-AX_ARG_DEFAULT_ENABLE([pythontools], [Disable Python tools])
AX_ARG_DEFAULT_ENABLE([ocamltools], [Disable Ocaml tools])
AX_ARG_DEFAULT_DISABLE([miniterm], [Enable miniterm])
AX_ARG_DEFAULT_DISABLE([lomount], [Enable lomount])
@@ -93,17 +92,15 @@ AS_IF([test "x$ocamltools" = "xy"], [
])
])
AX_PATH_PROG_OR_FAIL([BASH], [bash])
-AS_IF([test "x$pythontools" = "xy"], [
- AS_IF([echo "$PYTHON" | grep -q "^/"], [
- PYTHONPATH=$PYTHON
- PYTHON=`basename $PYTHONPATH`
- ],[test -z "$PYTHON"], [PYTHON="python"],
- [AC_MSG_ERROR([PYTHON specified, but is not an absolute path])])
- AX_PATH_PROG_OR_FAIL([PYTHONPATH], [$PYTHON])
- AX_CHECK_PYTHON_VERSION([2], [3])
- AX_CHECK_PYTHON_DEVEL()
- ])
- AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
+AS_IF([echo "$PYTHON" | grep -q "^/"], [
+ PYTHONPATH=$PYTHON
+ PYTHON=`basename $PYTHONPATH`
+],[test -z "$PYTHON"], [PYTHON="python"],
+[AC_MSG_ERROR([PYTHON specified, but is not an absolute path])])
+AX_PATH_PROG_OR_FAIL([PYTHONPATH], [$PYTHON])
+AX_CHECK_PYTHON_VERSION([2], [3])
+ AX_CHECK_PYTHON_DEVEL()
+AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
dnl as86, ld86, bcc and iasl are only required when the host system is x86*.
dnl "host" here means the platform on which the hypervisor and tools is
dnl going to run, not the platform on which we are building (known as