aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Jackson <ian.jackson@eu.citrix.com>2012-05-11 18:58:57 +0100
committerIan Jackson <ian.jackson@eu.citrix.com>2012-05-11 18:58:57 +0100
commitdb1a2ddef44cf1e908b44559e383553488e026f1 (patch)
treead66d4ccebcaa73e49ba13019571e1461cfef54b /tools/configure.ac
parent6eba329a1468c4092b7c7b4da0dc8df6acb87d30 (diff)
downloadxen-db1a2ddef44cf1e908b44559e383553488e026f1.tar.gz
xen-db1a2ddef44cf1e908b44559e383553488e026f1.tar.bz2
xen-db1a2ddef44cf1e908b44559e383553488e026f1.zip
autoconf: New test for openpty et al.
We may need to #include <libutil.h>, and/or link with -lutil, to use openpty, login_tty, and the like. Provide INCLUDE_LIBUTIL_H (preprocessor constant, not always defined) and PTYFUNCS_LIBS (makefile variable). We link libxl against PTYFUNCS_LIBS (which comes from autoconf) rather than UTIL_LIBS, and #include <libutil.h> where appropriate. Signed-off-by: Ian Jackson <ian.jackson@eu.citrix.com> Acked-by: Ian Campbell <ian.campbell@citrix.com> Changes since v7: * Actually include the call to AX_CHECK_PTYFUNCS in this patch, not the previous one, and regenerate configure accordingly. Changes since v6: * Put failure macro call in correct place so it might actually happen. * Try both with -lutil and without. * Patch now contains update for config.h.in. Committed-by: Ian Jackson <Ian.Jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index deb848d3d2..4e9cb03627 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -32,6 +32,7 @@ m4_include([m4/uuid.m4])
m4_include([m4/pkg.m4])
m4_include([m4/curses.m4])
m4_include([m4/pthread.m4])
+m4_include([m4/ptyfuncs.m4])
# Enable/disable options
AX_ARG_DEFAULT_DISABLE([githttp], [Download GIT repositories via HTTP])
@@ -132,6 +133,7 @@ AC_SUBST(libext2fs)
AC_CHECK_LIB([gcrypt], [gcry_md_hash_buffer], [libgcrypt="y"], [libgcrypt="n"])
AC_SUBST(libgcrypt)
AX_CHECK_PTHREAD
+AX_CHECK_PTYFUNCS
AC_CHECK_LIB([yajl], [yajl_alloc], [],
[AC_MSG_ERROR([Could not find yajl])])
AC_CHECK_LIB([z], [deflateCopy], [], [AC_MSG_ERROR([Could not find zlib])])