aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorDario Faggioli <raistlin@linux.it>2012-07-06 13:17:45 +0100
committerDario Faggioli <raistlin@linux.it>2012-07-06 13:17:45 +0100
commitd01089fc667ec8f2c64036882c9e8fb16d6162df (patch)
tree324273529ba883f4081d29f3f211efd00eca51c3 /tools/configure.ac
parent8cea5d337f061c39ec2c639f262becd49dafe361 (diff)
downloadxen-d01089fc667ec8f2c64036882c9e8fb16d6162df.tar.gz
xen-d01089fc667ec8f2c64036882c9e8fb16d6162df.tar.bz2
xen-d01089fc667ec8f2c64036882c9e8fb16d6162df.zip
libxl: explicitly check for libmath in autoconf
As well as explicitly add -lm to libxl's Makefile. This is because next patch uses floating point arithmetic, and it is better to state it clearly that we need libmath (just in case we find a libc that wants that to be explicitly enforced). Notice that autoconf should be rerun after applying this change. Signed-off-by: Dario Faggioli <dario.faggioli@citrix.com> Acked-by: Roger Pau Monne <roger.pau@citrix.com> Acked-by: Ian Campbell <ian.campbell@citrix.com> [ ijc -- s/libmath/libm/ in error message ] Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 8587eef77f..d3e0c1458e 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -133,6 +133,7 @@ AC_CHECK_LIB([lzo2], [lzo1x_decompress], [zlib="$zlib -DHAVE_LZO1X -llzo2"])
AC_SUBST(zlib)
AC_CHECK_LIB([aio], [io_setup], [system_aio="y"], [system_aio="n"])
AC_SUBST(system_aio)
+AC_CHECK_LIB([m], [isnan], [], [AC_MSG_ERROR([Could not find libm])])
AC_CHECK_LIB([crypto], [MD5], [], [AC_MSG_ERROR([Could not find libcrypto])])
AC_CHECK_LIB([ext2fs], [ext2fs_open2], [libext2fs="y"], [libext2fs="n"])
AC_SUBST(libext2fs)