aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-09-12 11:34:12 +0100
committerIan Campbell <ian.campbell@citrix.com>2013-09-17 17:39:53 +0100
commitcf59b4cd9f85631d4c38d6df05e7e432fca5a8f0 (patch)
treef36a5bb978957daccc890caedb1d4b95cc710e6f /tools/configure.ac
parentd3900dea28f9ab8207c35365b5fee2058b68fe91 (diff)
downloadxen-cf59b4cd9f85631d4c38d6df05e7e432fca5a8f0.tar.gz
xen-cf59b4cd9f85631d4c38d6df05e7e432fca5a8f0.tar.bz2
xen-cf59b4cd9f85631d4c38d6df05e7e432fca5a8f0.zip
tools: disable xend build by default
Add big warnings to configure, xend initscript and xm. The big xm warning is displayed once (per boot, or per tmpreaper clean), afterwards a single line warning is displayed. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 2e57bfc0a0..4f3c33a306 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -57,7 +57,7 @@ AX_ARG_DEFAULT_DISABLE([ovmf], [Enable OVMF])
AX_ARG_DEFAULT_ENABLE([rombios], [Disable ROM BIOS])
AX_ARG_DEFAULT_ENABLE([seabios], [Disable SeaBIOS])
AX_ARG_DEFAULT_ENABLE([debug], [Disable debug build of tools])
-AX_ARG_DEFAULT_ENABLE([xend], [Disable xend toolstack])
+AX_ARG_DEFAULT_DISABLE([xend], [Enable xend toolstack])
AX_ARG_DEFAULT_DISABLE([blktap1], [Disable blktap1 tools])
AC_ARG_ENABLE([qemu-traditional],
@@ -220,3 +220,16 @@ AC_SUBST(libiconv)
AC_CHECK_HEADERS([yajl/yajl_version.h sys/eventfd.h])
AC_OUTPUT()
+
+AS_IF([test "x$xend" = "xy" ], [
+ AC_MSG_WARN(
+[You have enabled the xend toolstack.
+
+xend is deprecated and scheduled for removal. Please migrate to another
+toolstack ASAP.
+
+See http://wiki.xen.org/wiki/Choice_of_Toolstacks for information on
+other alternatives, including xl which is designed to be a drop in
+replacement for xm (http://wiki.xen.org/wiki/XL).
+])
+])