aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorOlaf Hering <olaf@aepfle.de>2012-07-04 15:46:16 +0100
committerOlaf Hering <olaf@aepfle.de>2012-07-04 15:46:16 +0100
commitc004a0fec2fa738d145497a658dbde5b83bdbed6 (patch)
tree1d031fe9302d4b5681adb61bcc8330b8c29c8b4b /tools/configure.ac
parentecf5a746f16fcbe8bb1e77c8463455d0e6c85e46 (diff)
downloadxen-c004a0fec2fa738d145497a658dbde5b83bdbed6.tar.gz
xen-c004a0fec2fa738d145497a658dbde5b83bdbed6.tar.bz2
xen-c004a0fec2fa738d145497a658dbde5b83bdbed6.zip
tools/configure.ac: add version check for glib2
xen-unstable fails to build in a SLES10SP4 environment since a long time because the included version of glib is slightly older than the required glib version. According to the glib docs version 2.12 includes base64 support, but SLES10 is shipped with glib 2.8.6: qemu-timer-common.o: In function `init_get_clock': /usr/src/packages/BUILD/xen-4.2.25432/non-dbg/tools/qemu-xen-dir/qemu-timer-common.c:57: undefined reference to `clock_gettime' qga/guest-agent-commands.o: In function `qmp_guest_file_write': qga/guest-agent-commands.c:249: undefined reference to `g_base64_decode' qga/guest-agent-commands.o: In function `qmp_guest_file_read': qga/guest-agent-commands.c:224: undefined reference to `g_base64_encode' collect2: ld returned 1 exit status make[3]: *** [qemu-ga] Error 1 Add a version check to toplevel configure to require at least glib 2.12. This makes sure configure can detect the condition early instead of failing later in the middle of tools build when qemu-upstream errors out. Please rerun autoconf after applying this. Signed-off-by: Olaf Hering <olaf@aepfle.de> Acked-by: Roger Pau Monné <roger.pau@citrix.com> Acked-by: Ian Campbell <ian.campbell@citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 706ee132a5..8587eef77f 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -115,7 +115,7 @@ AX_PATH_PROG_OR_FAIL([BCC], [bcc])
AX_PATH_PROG_OR_FAIL([IASL], [iasl])
AX_CHECK_UUID
AX_CHECK_CURSES
-PKG_CHECK_MODULES(glib, glib-2.0)
+PKG_CHECK_MODULES(glib, [glib-2.0 >= 2.12])
# Check library path
AX_DEFAULT_LIB