aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorOlaf Hering <olaf@aepfle.de>2013-02-05 11:31:11 +0000
committerOlaf Hering <olaf@aepfle.de>2013-02-05 11:31:11 +0000
commita2a9b63b48a0f3440929cad1d60c691900430c3d (patch)
treeca864d2b64a33ef63275935121c402b083fbbd93 /tools/configure.ac
parentc23e8e7d5082cbf68611135af24d4a8ec38cb708 (diff)
downloadxen-a2a9b63b48a0f3440929cad1d60c691900430c3d.tar.gz
xen-a2a9b63b48a0f3440929cad1d60c691900430c3d.tar.bz2
xen-a2a9b63b48a0f3440929cad1d60c691900430c3d.zip
tools: update ocamlfind handling
configure checks just for ocamlc, but the tools in tools/ocaml depend also on ocamlfind. On my workstation I have just ocamlc installed, but no ocamlfind. As a result make will fail. Update configure.ac to check also for OCAMLFIND, update various Makefiles and replace hardcoded ocamlfind string with $(OCAMLFIND) Please rerun autogen.sh after applying this patch. Signed-off-by: Olaf Hering <olaf@aepfle.de> Acked-by: Ian Campbell <ian.campbell@citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 2bd71b6adc..de5d085974 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -86,7 +86,8 @@ AS_IF([test "x$xapi" = "xy"], [
])
AS_IF([test "x$ocamltools" = "xy"], [
AC_PROG_OCAML
- AS_IF([test "x$OCAMLC" = "xno"], [
+ AC_PROG_FINDLIB
+ AS_IF([test "x$OCAMLC" = "xno" || test "x$OCAMLFIND" = "xno"], [
AS_IF([test "x$enable_ocamltools" = "xyes"], [
AC_MSG_ERROR([Ocaml tools enabled, but unable to find Ocaml])])
ocamltools="n"