aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2012-05-14 16:22:39 +0100
committerRoger Pau Monne <roger.pau@citrix.com>2012-05-14 16:22:39 +0100
commit9a3fe991fdd744485f0a59743f421c785986963b (patch)
treeba829753f2f120e4a3a19357f0c5ba9423adaf27 /tools/configure.ac
parentbc934837c2ac48e4b5ca05b6e397f7f9f780ff82 (diff)
downloadxen-9a3fe991fdd744485f0a59743f421c785986963b.tar.gz
xen-9a3fe991fdd744485f0a59743f421c785986963b.tar.bz2
xen-9a3fe991fdd744485f0a59743f421c785986963b.zip
autoconf: check for dev86 and iasl on x86* only
Check for this tools on x86 systems only. Signed-off-by: Roger Pau Monne <roger.pau@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Committed-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 4e9cb03627..706ee132a5 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -67,10 +67,16 @@ AC_ARG_VAR([CURL], [Path to curl-config tool])
AC_ARG_VAR([XML], [Path to xml2-config tool])
AC_ARG_VAR([BASH], [Path to bash shell])
AC_ARG_VAR([XGETTEXT], [Path to xgetttext tool])
-AC_ARG_VAR([AS86], [Path to as86 tool])
-AC_ARG_VAR([LD86], [Path to ld86 tool])
-AC_ARG_VAR([BCC], [Path to bcc tool])
-AC_ARG_VAR([IASL], [Path to iasl tool])
+
+dnl as86, ld86, bcc and iasl are only present in x86* systems
+case "$host_cpu" in
+i[[3456]]86|x86_64)
+ AC_ARG_VAR([AS86], [Path to as86 tool])
+ AC_ARG_VAR([LD86], [Path to ld86 tool])
+ AC_ARG_VAR([BCC], [Path to bcc tool])
+ AC_ARG_VAR([IASL], [Path to iasl tool])
+ ;;
+esac
# Checks for programs.
AC_PROG_CC