aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorFabio Fantoni <fabio.fantoni@m2r.biz>2013-09-05 12:40:01 +0200
committerIan Campbell <ian.campbell@citrix.com>2013-09-09 14:48:51 +0100
commit906677d6411c3dc579e07967d0137a12392ff314 (patch)
tree677e839e210b259b38c4adc869d395da447e3d54 /tools/configure.ac
parent4d10a505c1eb6feb85292ab944c18e28f5583294 (diff)
downloadxen-906677d6411c3dc579e07967d0137a12392ff314.tar.gz
xen-906677d6411c3dc579e07967d0137a12392ff314.tar.bz2
xen-906677d6411c3dc579e07967d0137a12392ff314.zip
tools: allow user to specify a system seabios binary
If this option is given don't bother building seabios ourselves. Likely to be handy for distros who have an existing seabios package which they want to reuse. Signed-off-by: Fabio Fantoni <fabio.fantoni@m2r.biz> Acked-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 1f576819a8..2e57bfc0a0 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -97,6 +97,17 @@ AS_IF([test "x$qemu_xen" = "xn"], [
])
AC_SUBST(qemu_xen)
+AC_ARG_WITH([system-seabios],
+ AS_HELP_STRING([--with-system-seabios@<:@=PATH@:>@],
+ [Use system supplied seabios PATH instead of building and installing
+ our own version]),[
+ case $withval in
+ no) seabios_path= ;;
+ *) seabios_path=$withval ;;
+ esac
+],[])
+AC_SUBST(seabios_path)
+
AC_ARG_VAR([PREPEND_INCLUDES],
[List of include folders to prepend to CFLAGS (without -I)])
AC_ARG_VAR([PREPEND_LIB],