aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@entel.upc.edu>2012-03-13 15:23:35 +0000
committerRoger Pau Monne <roger.pau@entel.upc.edu>2012-03-13 15:23:35 +0000
commit65da4913214120ddc95bd846cb3649a29f87146a (patch)
tree0184962f72ff86a39430e6a0958ee15fcbcfb977 /tools/configure.ac
parent77b8dfec88acdc71138e3af7e2603ad8d72eb926 (diff)
downloadxen-65da4913214120ddc95bd846cb3649a29f87146a.tar.gz
xen-65da4913214120ddc95bd846cb3649a29f87146a.tar.bz2
xen-65da4913214120ddc95bd846cb3649a29f87146a.zip
autoconf: add check for curses library
Check for a curses compatible library (curses or ncurses basically). One of those is needed to compile Xen tools (gtraceview and xentop). Modify Makefiles/sources to use configure output (fetch CURSES_LIBS from tools/Tools.mk and header to include from tools/config.h) Signed-off-by: Roger Pau Monne <roger.pau@entel.upc.edu> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Committed-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index c4afe1cf77..cf376bf05f 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -33,6 +33,7 @@ m4_include([m4/default_lib.m4])
m4_include([m4/set_cflags_ldflags.m4])
m4_include([m4/uuid.m4])
m4_include([m4/pkg.m4])
+m4_include([m4/curses.m4])
# Enable/disable options
AX_ARG_ENABLE_AND_EXPORT([githttp], [Download GIT repositories via HTTP])
@@ -98,6 +99,7 @@ AS_IF([test "x$pythontools" = "xy"], [
])
AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
AX_CHECK_UUID
+AX_CHECK_CURSES
PKG_CHECK_MODULES(glib, glib-2.0)
# Check library path