aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2012-04-25 11:44:09 +0100
committerRoger Pau Monne <roger.pau@citrix.com>2012-04-25 11:44:09 +0100
commit5fce16c040f5e4fae51c5ad0db08f2cf3cd26094 (patch)
tree6e1c5b271c6543ce752002fa411d543512a0fb8f /tools/configure.ac
parentd9abcb8495b2d481611f8d47b45680e5d9984a33 (diff)
downloadxen-5fce16c040f5e4fae51c5ad0db08f2cf3cd26094.tar.gz
xen-5fce16c040f5e4fae51c5ad0db08f2cf3cd26094.tar.bz2
xen-5fce16c040f5e4fae51c5ad0db08f2cf3cd26094.zip
libxl, configure: print a warning if flex/bison are needed
This patch adds better support for both Flex and Bison, which might be needed to compile libxl. Now configure script sets BISON and FLEX Makefile vars if bison and flex are found, but doesn't complain if they are not found. Also, added some Makefile soccery to print a warning message if Bison or Flex are needed but not found. [ Improved the warning message slightly. -iwj ] Signed-off-by: Roger Pau Monne <roger.pau@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Signed-off-by: Ian Jackson <ian.jackson@eu.citrix.com> Committed-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 11a743f485..57c887d15a 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -80,6 +80,8 @@ AC_PROG_CC
AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_INSTALL
+AC_PATH_PROG([BISON], [bison])
+AC_PATH_PROG([FLEX], [flex])
AX_PATH_PROG_OR_FAIL([PERL], [perl])
AS_IF([test "x$xapi" = "xy"], [
AX_PATH_PROG_OR_FAIL([CURL], [curl-config])