aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-03-15 13:15:45 +0000
committerIan Campbell <ian.campbell@citrix.com>2013-04-11 11:09:25 +0100
commit2a6068822dea6429201f6f44e229663ba7858c27 (patch)
tree94a9c371dd06ccfd7532cfa873ec24e44e9c7a74 /tools/configure.ac
parentcc9b8e3f334dc9d6d9e9a3b19065104204aa56f7 (diff)
downloadxen-2a6068822dea6429201f6f44e229663ba7858c27.tar.gz
xen-2a6068822dea6429201f6f44e229663ba7858c27.tar.bz2
xen-2a6068822dea6429201f6f44e229663ba7858c27.zip
tools: only check for Python devel tools if not cross-compiling.
tools/python and tools/pygrub are already skipped in tools/Makefile when cross-compiling, so no point in checking for the prerequisites either. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 36a3343b87..c5eb2b1893 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -121,7 +121,11 @@ AS_IF([echo "$PYTHON" | grep -q "^/"], [
[AC_MSG_ERROR([PYTHON specified, but is not an absolute path])])
AX_PATH_PROG_OR_FAIL([PYTHONPATH], [$PYTHON])
AX_CHECK_PYTHON_VERSION([2], [3])
- AX_CHECK_PYTHON_DEVEL()
+
+AS_IF([test "$cross_compiling" != yes], [
+ AX_CHECK_PYTHON_DEVEL()
+])
+
AX_PATH_PROG_OR_FAIL([XGETTEXT], [xgettext])
dnl as86, ld86, bcc and iasl are only required when the host system is x86*.
dnl "host" here means the platform on which the hypervisor and tools is