aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-03-15 13:15:42 +0000
committerIan Campbell <ian.campbell@citrix.com>2013-04-11 11:09:25 +0100
commit1cc48e865b2faa3f8147c15fcec4c24c46b3d63f (patch)
treec2648a67386823d6b9a0e6776eb326683455cee8 /tools/configure.ac
parenteb60be3dd870aecfa47bed1118069680389c15f7 (diff)
downloadxen-1cc48e865b2faa3f8147c15fcec4c24c46b3d63f.tar.gz
xen-1cc48e865b2faa3f8147c15fcec4c24c46b3d63f.tar.bz2
xen-1cc48e865b2faa3f8147c15fcec4c24c46b3d63f.zip
tools: Use AC_SYS_LARGEFILE instead of calling getconf(1)
getconf is not cross-compile friendly since it reports the features of the host and not the target. There doesn't appear to be a $triplet-getconf. AC_SYS_LARGEFILE arranges for #defines to appear in config.h however Xen's build system expects these to be part of C{PP}FLAGS. Since I'm not confident that everything in Xen includes config.h I instead arrange for the result of running AC_SYS_LARGERFILE to end up in CFLAGS. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 0d384087f4..f6e2fec2af 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -21,6 +21,16 @@ APPEND_INCLUDES and APPEND_LIB instead when possible.])
AC_CANONICAL_HOST
+AC_SYS_LARGEFILE
+
+case $ac_cv_sys_file_offset_bits in #(
+ no | unknown) ;;
+ *)
+ FILE_OFFSET_BITS=$ac_cv_sys_file_offset_bits
+;;
+esac
+AC_SUBST(FILE_OFFSET_BITS)
+
# M4 Macro includes
m4_include([../m4/savevar.m4])
m4_include([../m4/features.m4])