aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorDaniel De Graaf <dgdegra@tycho.nsa.gov>2012-03-01 15:22:09 +0000
committerDaniel De Graaf <dgdegra@tycho.nsa.gov>2012-03-01 15:22:09 +0000
commit1b21c0b45981cfe56777075e51268eed0371bbf2 (patch)
treefa32885548e4e2e27588c164aae9eb8c3439b9f4 /tools/configure.ac
parenta55f818f8b43da55c139b9f97f85e4dd8ea320b2 (diff)
downloadxen-1b21c0b45981cfe56777075e51268eed0371bbf2.tar.gz
xen-1b21c0b45981cfe56777075e51268eed0371bbf2.tar.bz2
xen-1b21c0b45981cfe56777075e51268eed0371bbf2.zip
build: remove hypervisor-only configuration from tools/configure
When adding autoconf support, the configuration options for XSM and FLASK_ENABLE were incorrectly removed from Config.mk and added to the tools configuration. Since these are hypervisor configuration options, they should not depend on running tools configuration. Signed-off-by: Daniel De Graaf <dgdegra@tycho.nsa.gov> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com> Committed-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 4dc2b695f7..e1b72f06a9 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -36,8 +36,6 @@ m4_include([m4/uuid.m4])
m4_include([m4/pkg.m4])
# Enable/disable options
-AX_ARG_ENABLE_AND_EXPORT([xsm],
- [Enable XSM security module (by default, Flask)])
AX_ARG_ENABLE_AND_EXPORT([githttp], [Download GIT repositories via HTTP])
AX_ARG_DISABLE_AND_EXPORT([monitors],
[Disable xenstat and xentop monitoring tools])
@@ -47,7 +45,7 @@ AX_ARG_DISABLE_AND_EXPORT([pythontools], [Disable Python tools])
AX_ARG_DISABLE_AND_EXPORT([ocamltools], [Disable Ocaml tools])
AX_ARG_ENABLE_AND_EXPORT([miniterm], [Enable miniterm])
AX_ARG_ENABLE_AND_EXPORT([lomount], [Enable lomount])
-AX_ARG_DISABLE_AND_EXPORT([debug], [Disable debug build of Xen and tools])
+AX_ARG_DISABLE_AND_EXPORT([debug], [Disable debug build of tools])
AC_ARG_VAR([PREPEND_INCLUDES],
[List of include folders to prepend to CFLAGS (without -I)])