aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2012-09-14 10:02:47 +0100
committerRoger Pau Monne <roger.pau@citrix.com>2012-09-14 10:02:47 +0100
commit19459d56f493b380e2df30e06822cc7b01183186 (patch)
tree9b397d655903efa89e6522badd7e33489f6d41d0 /tools/configure.ac
parent393a6e75afb627fe126bfc8050bd53b9e086e1dc (diff)
downloadxen-19459d56f493b380e2df30e06822cc7b01183186.tar.gz
xen-19459d56f493b380e2df30e06822cc7b01183186.tar.bz2
xen-19459d56f493b380e2df30e06822cc7b01183186.zip
libfsimage: add ext4 support for CentOS 5.x
CentOS 5.x forked e2fs ext4 support into a different package called e4fs, and so headers and library names changed from ext2fs to ext4fs. Check if ext4fs/ext2fs.h and -lext4fs work, and use that instead of ext2fs to build libfsimage. This patch assumes that if the ext4fs library is present it should always be used instead of ext2fs. This patch includes a rework of the ext2fs check, a new ext4fs check and a minor modification in libfsimage to use the correct library. Signed-off-by: Roger Pau Monne <roger.pau@citrix.com> Acked-by: Ian Campbell <ian.campbell@citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 703a24bf33..3b3ce42323 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -34,6 +34,7 @@ m4_include([m4/pkg.m4])
m4_include([m4/curses.m4])
m4_include([m4/pthread.m4])
m4_include([m4/ptyfuncs.m4])
+m4_include([m4/extfs.m4])
# Enable/disable options
AX_ARG_DEFAULT_DISABLE([githttp], [Download GIT repositories via HTTP])
@@ -131,8 +132,7 @@ AC_SUBST(zlib)
AC_CHECK_LIB([aio], [io_setup], [system_aio="y"], [system_aio="n"])
AC_SUBST(system_aio)
AC_CHECK_LIB([crypto], [MD5], [], [AC_MSG_ERROR([Could not find libcrypto])])
-AC_CHECK_LIB([ext2fs], [ext2fs_open2], [libext2fs="y"], [libext2fs="n"])
-AC_SUBST(libext2fs)
+AX_CHECK_EXTFS
AC_CHECK_LIB([gcrypt], [gcry_md_hash_buffer], [libgcrypt="y"], [libgcrypt="n"])
AC_SUBST(libgcrypt)
AX_CHECK_PTHREAD