aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorDaniel De Graaf <dgdegra@tycho.nsa.gov>2013-02-13 16:06:57 +0000
committerIan Jackson <Ian.Jackson@eu.citrix.com>2013-02-22 17:16:35 +0000
commit13dd8043cda1efeb683a05b995cb134e9662b87b (patch)
tree9e2150774f6eff6e80d422d9226034a91e54ff2a /tools/configure.ac
parent2393441e5808b5ac4d76510560b3200c91f67409 (diff)
downloadxen-13dd8043cda1efeb683a05b995cb134e9662b87b.tar.gz
xen-13dd8043cda1efeb683a05b995cb134e9662b87b.tar.bz2
xen-13dd8043cda1efeb683a05b995cb134e9662b87b.zip
tools/flask: add FLASK policy to build
This patch enables the compilation of the FLASK policy as part of the tools build if the needed prerequisites are present. Signed-off-by: Daniel De Graaf <dgdegra@tycho.nsa.gov> Signed-off-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index de5d085974..0d384087f4 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -28,6 +28,7 @@ m4_include([../m4/path_or_fail.m4])
m4_include([../m4/python_version.m4])
m4_include([../m4/python_devel.m4])
m4_include([../m4/ocaml.m4])
+m4_include([../m4/checkpolicy.m4])
m4_include([../m4/set_cflags_ldflags.m4])
m4_include([../m4/uuid.m4])
m4_include([../m4/pkg.m4])
@@ -42,6 +43,7 @@ AX_ARG_DEFAULT_DISABLE([githttp], [Download GIT repositories via HTTP])
AX_ARG_DEFAULT_ENABLE([monitors], [Disable xenstat and xentop monitoring tools])
AX_ARG_DEFAULT_DISABLE([xenapi], [Enable Xen API Bindings])
AX_ARG_DEFAULT_ENABLE([ocamltools], [Disable Ocaml tools])
+AX_ARG_DEFAULT_ENABLE([xsmpolicy], [Disable XSM policy compilation])
AX_ARG_DEFAULT_DISABLE([miniterm], [Enable miniterm])
AX_ARG_DEFAULT_DISABLE([lomount], [Enable lomount])
AX_ARG_DEFAULT_DISABLE([ovmf], [Enable OVMF])
@@ -93,6 +95,14 @@ AS_IF([test "x$ocamltools" = "xy"], [
ocamltools="n"
])
])
+AS_IF([test "x$xsmpolicy" = "xy"], [
+ AC_PROG_CHECKPOLICY
+ AS_IF([test "x$CHECKPOLICY" = "xno"], [
+ AS_IF([test "x$enable_xsmpolicy" = "xyes"], [
+ AC_MSG_ERROR([XSM policy compilation enabled, but unable to find checkpolicy])])
+ xsmpolicy="n"
+ ])
+])
AX_PATH_PROG_OR_FAIL([BASH], [bash])
AS_IF([echo "$PYTHON" | grep -q "^/"], [
PYTHONPATH=$PYTHON