aboutsummaryrefslogtreecommitdiffstats
path: root/tools/configure.ac
diff options
context:
space:
mode:
authorIan Campbell <ian.campbell@citrix.com>2013-07-31 16:15:50 +0100
committerIan Campbell <ian.campbell@citrix.com>2013-08-20 15:33:54 +0100
commit03145f0fe42c007834c1ef50d95fe6c4f58a326a (patch)
tree83b0a7896a8de2e13237ce33b43a625f0472dd98 /tools/configure.ac
parent9af42f3598ba6f4b38384fdd2038c30f7ec763b9 (diff)
downloadxen-03145f0fe42c007834c1ef50d95fe6c4f58a326a.tar.gz
xen-03145f0fe42c007834c1ef50d95fe6c4f58a326a.tar.bz2
xen-03145f0fe42c007834c1ef50d95fe6c4f58a326a.zip
tools: make building xend configurable.
xend has been deprecated for 2 releases now. Lets make it possible to not even build it. For now I'm leaving the default of on but I would like to change that before the 4.4 release. Signed-off-by: Ian Campbell <ian.campbell@citrix.com> Reviewed-by: Andrew Cooper <andrew.cooper3@citrix.com> Acked-by: Matt Wilson <msw@amazon.com> Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'tools/configure.ac')
-rw-r--r--tools/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/configure.ac b/tools/configure.ac
index 4f5e688ce2..d6eba44315 100644
--- a/tools/configure.ac
+++ b/tools/configure.ac
@@ -59,6 +59,7 @@ AX_ARG_DEFAULT_DISABLE([ovmf], [Enable OVMF])
AX_ARG_DEFAULT_ENABLE([rombios], [Disable ROM BIOS])
AX_ARG_DEFAULT_ENABLE([seabios], [Disable SeaBIOS])
AX_ARG_DEFAULT_ENABLE([debug], [Disable debug build of tools])
+AX_ARG_DEFAULT_ENABLE([xend], [Disable xend toolstack])
AC_ARG_VAR([PREPEND_INCLUDES],
[List of include folders to prepend to CFLAGS (without -I)])